Subject: DBD::Oracle Slow cursors

From: Calin Medianu <[email-masked]>
Date: Mon, 29 Apr 2002 13:18:53 -0700 (PDT)

Hello,

I did the following. Wrote a perl script that retreves
data via a straight select from the database. Then I
wrote a stored procedure returning a ref cursor open
on the same select statement and retrieved the data as
well. Using the REF CURSOR/ sotred procedure was about
3 time slower, that is 40 seconds instead of around
10.

Is this normal? Is this a problem with oracle or with
DBD::Oracle?

Thanks,

Calin Medianu

__________________________________________________
Do You Yahoo!?
Yahoo! Health - your guide to health and wellness
http://health.yahoo.com

---

From: Tim Bunce <[email-masked]>
Date: Mon, 29 Apr 2002 23:31:38 +0100

> Is this normal? Is this a problem with oracle or with

DBD::Oracle. It probably isn't setting up a row cache for the ref cursor.

Get a level 3 trace and look for the "dbd_describe'd" line for the
ref cursor.

Tim.